* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 13
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Recent Topics

Looking for a TK by towman2018
[October 24, 2020, 10:13:01 PM]


engineer certificate by johng
[October 13, 2020, 04:17:14 PM]


Daily Post by outriding
[July 25, 2020, 05:19:57 AM]


CF Workshop Manual by stuuuz
[May 24, 2020, 12:21:25 PM]


Side Door PINS in Hinge (What SIze Are they) CF Bedford SWB1977 by Hobbit
[May 21, 2020, 03:22:38 PM]


Test Gallery Image by wendyh
[April 16, 2020, 09:24:38 PM]


Franky's new LS1 heart transplant by baz
[April 01, 2020, 12:28:28 PM]


Roof removal by phill
[February 01, 2020, 02:40:46 PM]


rust repairs begin by wendyh
[January 30, 2020, 06:45:47 AM]


roof removal by wendyh
[January 30, 2020, 06:44:42 AM]

Author Topic: My Bedford Wiring Is A Disgrace!  (Read 9046 times)

0 Members and 1 Guest are viewing this topic.

Offline Hashman

  • Gumbie
  • *
  • Location: Melbourne, Australia
  • Posts: 24
    • View Profile
    • SKW4X4
My Bedford Wiring Is A Disgrace!
« on: August 06, 2009, 11:01:58 PM »
Trying to get the beddie roadworthy and it seems to be one thing after another!  Just got a new 2" exhaust system to also find out the mainfold gasket is also gone.  Windscreen wipers seem to have two settings but just the ONE SLOW speed and now I keep losing different headlights when it feels like it.

Wiring or switches ya reckon?  Hi beam works well but the normal beam works intermittantly.  The wipers someone reckons its just the switch but i got a 2nd hand motor just incase.

Anyone know a good auto elec in eastern suburbs of melb or should i give this a go myself?  Any ideas of which things to try 1st and how?

thanks for any input

dave

Offline BusyKiwi

  • Global Moderator +
  • Apprentice Mechanic
  • *****
  • Location: Hamilton, NZ
  • Posts: 1697
  • Still in progress
    • View Profile
    • munchtech.com
Re: My Bedford Wiring Is A Disgrace!
« Reply #1 on: August 07, 2009, 06:32:37 AM »
spray some CRC into the back of the switches, sounds like dirty connections.
There are so many people out there who will tell you that you can't. What you've got to do is turn around and say "watch me"

Offline obsession

  • Global Moderator
  • Apprentice Mechanic
  • *****
  • Location: perth
  • Posts: 2108
  • canning vale western australia
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #2 on: August 07, 2009, 07:23:15 AM »
take the plugs out where they join the firewall and clean the frak out of the contact blocks youll find things working you never new you had. 8) :o

go round and do as many earths as you can

there is a good contact spray available just for this but its about $30 a can but well worth it , it is from the crc range blue and white can I think. :P




Topic: My Bedford Wiring Is A Disgrace!  (Read 17 times)


YOUR NOT ALONE....................................................
« Last Edit: August 07, 2009, 07:27:44 AM by craig »
ur a bedford owner ....adapt overcome work it out

Offline eddy

  • Global Moderator
  • Apprentice Mechanic
  • *****
  • Location: Melbourne, Vic
  • Posts: 890
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #3 on: August 07, 2009, 10:32:13 PM »
wiring ?? ouch  :-X  hey bro I got a wiring diagram if ya want to photocopy it, I'm on Ringwood North  ;)
ekm ...... never lead with your chin, let others lead with theirs

Offline Warren

  • Global Moderator +
  • Apprentice Mechanic
  • *****
  • Location: Croydon Melbourne VIC
  • Posts: 1536
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #4 on: August 08, 2009, 10:42:15 AM »
Wiring  - the bain of any sain man hey Eddy  ;)
We need to get a start on the tow beddys :(
I used to be vague..................Now I'm not so sure

Offline ben

  • Apprentice Mechanic
  • *****
  • Location: Yarram, Vic
  • Posts: 3497
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #5 on: August 09, 2009, 04:54:59 PM »
wiring is always a nightmare. in fact  i have a desire to spend some time with an auto electrician to find out how he thinks.

last electrician i took a wiring mess to he got really nervous and ran away. bedfords:)

Offline Warren

  • Global Moderator +
  • Apprentice Mechanic
  • *****
  • Location: Croydon Melbourne VIC
  • Posts: 1536
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #6 on: August 09, 2009, 10:56:12 PM »
Hey Dave

Give it a go yourself. it's not to hard if you have an understanding of the basics, you just tneed to be thorough, persistant and patient.

Get yourself a wiring diagram, multimeter and a 4 meter length of insulated wire with aligator clips on each end.

Wiring diagrams can look confusing, but if you isolate one thing, and then follow it through you will soon see how it works, spend a lot of time following each of the individual elements, doing this will help you understand all the circuits and recognise the wire colours, switches etc. Do this research befor you even touch the tools.

Having touble understanding it all, break it down, for any circuit to work electrons have to flow from the positive post of the battery through a cable to the device and then through to the negative terminal of the battery. This can be done all with wire, but to save on wire they use the metal body as the return path to the battery.

Mmm this is getting bigger than I planned....I've been thinking of penning a tech artical on electrics - time to do it.

I will PM you my number

Warren

 


   
I used to be vague..................Now I'm not so sure

Offline Marishka

  • Global Moderator
  • Apprentice Mechanic
  • *****
  • Location: on a farm in NSW
  • Posts: 1947
  • AKA mty
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #7 on: August 09, 2009, 11:08:05 PM »
bear in mind that faulty wiring can start fires, :(
ive seen this first hand.
make sure u use the right gauge wires for the application
marty

Offline Merlin

  • Just streetable
  • ****
  • Location: casaurina perth wa
  • Posts: 429
    • View Profile
Re: My Bedford Wiring Is A Disgrace!
« Reply #8 on: August 10, 2009, 02:26:34 AM »
disconect the battery pull out all your fuses and clean the fuse box contacts with a bit of wet n dry clean the fuses to and you will find its a murkle!!! ;D ;D it worked great for me

Offline Hashman

  • Gumbie
  • *
  • Location: Melbourne, Australia
  • Posts: 24
    • View Profile
    • SKW4X4
Re: My Bedford Wiring Is A Disgrace!
« Reply #9 on: August 10, 2009, 11:34:18 AM »
Wow thanks guys for the help!  So far all ive had time for was remove the plugs on the firewall and use some contact cleaner but headlight still dodgey.  Have a feelings its the mess behind the intrusment cluster or possibly the fuse holder that merlin mentioned.  I do have a wiring diagram in my haynes workshop manual and will slowly go through it.  Might change relay over.

 I also found out what the extra switch on the dash is.  Someone at sometime has wired up a hazards light as there is an extra flasher there with nothing attached.  Previous owners did a custom dash from cluster to passenger door and i think were a little slap happy hooking everything back up!

Wish me luck!  ;D

 

anything
SimplePortal 2.3.7 © 2008-2020, SimplePortal